AppPool Immediately Stops when Launch an APP (Service UnAvailable) in SharePoint 2013


Sathish Nadarajan
SharePoint MVP
Published On :   22 Oct 2015
Visit Count
Today :  1    Total :   4367
Plan, Migrate, Secure, Report
SharePoint & Office 365 Tool. Simple & Easy to Use. 15-Day Trial!

SharePoint Office 365 Tool
Simple & Powerful Tool for Migration, Security & Reporting. Free Trial


Most of the SharePoint APP Developers would have come across this scenario. Our APP Pool stops abruptly for no reason.

Scenario:

When we launch an APP from our SharePoint Site, the corresponding APP Pool will be stopped and on the Screen we will get the “Service UnAvailable” exception.

Resolution:

1. Check whether the AppPool Identity has the access to the Content DB. Because, sometimes, what happens, if it does not have access, this will lock the account and locked account will abruptly without any intimation, stops the AppPool.

2. Check for the McCafe installation. Refer to this Link.

Quote from the above Link.

1. Click Start, Run, type explorer and click OK.

2. Navigate to: %windir%\system32\inetsrv\config

3. Open the file applicationHost.config as Administrator for editing in Notepad.

4. Edit the <globalModules> section and remove the following line:

<add name="MfeEngine" image="%windir%\System32\inetsrv\HipIISEngineStub.dll" />

5. Edit the <modules> section and remove the following line:

<add name="MfeEngine" />

6. After you have finished editing the applicationHost.config file, save the file, then restart the IIS server using iisreset or by restarting the system.

3. The third easiest solution would be, delete the AppPool. Create a new AppPool and map your applications to the newer one. That is going to be the easiest solution.

 

 

Happy Coding,

Sathish Nadarajan.

SharePoint Usage Reports
Usage reports, collaboration and audit for SharePoint.
Categories

Migratiin Tools for SharePoint